Newsletter Failing

Incident Report for Open Research Calendar

Monitoring

We have implemented the new mailing system. The next scheduled send is on 1st June, and the outcome will be monitored.

There has been a change in the email address. Subscribers should expect an email from: hello@newsletter.openresearchcalendar.org

The email address does not accept incoming mail. All contact should be made through GitHub Discussions/Issues
Posted May 19, 2025 - 13:20 UTC

Identified

We are trialling an implementation of Sinch Mailgun. Development of the automation is underway. The Open Research Calendar Data Use policy will be updated to reflect the addition of a new data processor.
Posted May 12, 2025 - 16:00 UTC

Update

We continue to explore alternative email platforms for the automated newsletter. A key priority is that the newsletter remains fully automated and that there is no cost for sending.

At the moment, new subscribers may not receive their subscription confirmation email. However, they will be successfully added to the subscribers list.
Posted May 08, 2025 - 12:00 UTC

Investigating

Problem: It is known that this month's automated newsletter has had issues being delivered to over 80% of subscribers. We are investigating and seeking a new platform to send emails.

Impact:
- Current subscribers may not have received this month's newsletter (https://openresearchcalendar.org/email-newsletter/archive/25_05_May_Newsletter)
- New subscribers may not receive their sign-up confirmation email.
Posted May 01, 2025 - 12:15 UTC
This incident affects: Automation (Monthly Newsletter).