Automation Error - Logic Failed

Incident Report for Open Research Calendar

Postmortem

CAUSE: A lack of filter that allowed the automation engine to search for Social Media posts that did not exist as it was out-of-hours (08:30-20:30 UTC).

RESULT: The result of this search was an error, which stopped the Edit-event automation.

FIX: Added a filter to find social media IDs before continuing the automation.

Posted Jan 09, 2026 - 22:25 UTC

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 22:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2026 - 22:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 09, 2026 - 22:02 UTC
This incident affected: Automation (Automation Engine, Edit Events).